Installing YARP in debian

Install dependencies

First follow Using xstow for local installations

  • Add this line to .bashrc
  export YARP_DATA_DIRS=${HOME}/local/share/yarp
  • Dependencies:
  sudo apt-get install git libace-dev libreadline6-dev libgtkmm-2.4-dev swig libopencv-highgui3.2 libopencv-core3.2 libopencv-dev cmake-curses-gui python-dev qt5-default qtmultimedia5-dev qtdeclarative5-dev qml-module-qtquick-dialogs qml-module-qt-labs-settings qml-module-qtmultimedia libopenmpi-dev qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings

Compilation and Installation

yarp_installer.sh
  cd ~/local/src/
  git clone git://github.com/robotology/yarp.git
  cd yarp
  mkdir build
  cd build
  cmake -D CMAKE_INSTALL_PREFIX=${HOME}/local/DIR/yarp -D YARP_COMPILE_BINDINGS=ON -D CREATE_PYTHON=OM -D YARP_USE_PYTHON_VERSION=$(echo $(python --version) | tr -d a-zA-Z[:blank:]) -D CREATE_YARPDATADUMPER=OFF -D CREATE_GUIS=ON -D ENABLE_yarpmod_opencv_grabber=ON ..
  make -j10
  make install
  cd ~/local/DIR
  xstow yarp

Test the installation

  • In one console run
yarpserver3
  • Connect a webcam to one of the usb ports of the computer
  • In another console run:
  yarpdev --verbose --device opencv_grabber
  • In another console run:
  yarpview
  • In another console run:
yarp connect /grabber /yarpview/img:i
  • To test yarp in python:
python -c "import yarp; buffer=yarp.BufferedPortBottle();"
  • You should not get any errors with any command

Update YARP

We try to use the latest yarp version. So some programs may present issues if you stay with old versions. Here are the instructions to updar with the same cmake options.

yarp_updater.sh
  cd ~/local/DIR
  xstow -D yarp
  cd ~/local/src/yarp
  git pull
  cd build
  make -j10
  make install
  cd ~/local/DIR
  xstow yarp
  • tutorials/installing_yarp_in_debian.txt
  • Last modified: 2019/05/06 08:41
  • by dgarcia